On Wed, Aug 28, 2024 at 02:34:21PM +0000, Edgecombe, Rick P wrote: > On Mon, 2024-08-12 at 15:48 -0700, Rick Edgecombe wrote: > > +static inline bool is_td_vcpu_created(struct vcpu_tdx *tdx) > > +{ > > + return tdx->td_vcpu_created; > > +} > > This and is_td_finalized() seem like unneeded helpers. The field name is clear > enough. I'll do a patch for this. > > static inline bool is_td_created(struct kvm_tdx *kvm_tdx) > > { > > return kvm_tdx->tdr_pa; > > Not this one though, the helper makes the caller code clearer. Yes this makes things more readable. Regards, Tony