On Tue, Aug 13, 2024 at 01:12:55PM +0800, Binbin Wu wrote: > Check whether a KVM hypercall needs to exit to userspace or not based on > hypercall_exit_enabled field of struct kvm_arch. > > Userspace can request a hypercall to exit to userspace for handling by > enable KVM_CAP_EXIT_HYPERCALL and the enabled hypercall will be set in > hypercall_exit_enabled. Make the check code generic based on it. > > Signed-off-by: Binbin Wu <binbin.wu@xxxxxxxxxxxxxxx> > --- > arch/x86/kvm/x86.c | 4 ++-- > arch/x86/kvm/x86.h | 7 +++++++ > 2 files changed, 9 insertions(+), 2 deletions(-) > > diff --git a/arch/x86/kvm/x86.c b/arch/x86/kvm/x86.c > index af6c8cf6a37a..6e16c9751af7 100644 > --- a/arch/x86/kvm/x86.c > +++ b/arch/x86/kvm/x86.c > @@ -10226,8 +10226,8 @@ int kvm_emulate_hypercall(struct kvm_vcpu *vcpu) > cpl = kvm_x86_call(get_cpl)(vcpu); > > ret = __kvm_emulate_hypercall(vcpu, nr, a0, a1, a2, a3, op_64_bit, cpl); > - if (nr == KVM_HC_MAP_GPA_RANGE && !ret) > - /* MAP_GPA tosses the request to the user space. */ > + if (!ret && is_kvm_hc_exit_enabled(vcpu->kvm, nr)) > + /* The hypercall is requested to exit to userspace. */ > return 0; > > if (!op_64_bit) > diff --git a/arch/x86/kvm/x86.h b/arch/x86/kvm/x86.h > index 50596f6f8320..0cbec76b42e6 100644 > --- a/arch/x86/kvm/x86.h > +++ b/arch/x86/kvm/x86.h > @@ -547,4 +547,11 @@ int kvm_sev_es_string_io(struct kvm_vcpu *vcpu, unsigned int size, > unsigned int port, void *data, unsigned int count, > int in); > > +static inline bool is_kvm_hc_exit_enabled(struct kvm *kvm, unsigned long hc_nr) > +{ > + if(WARN_ON_ONCE(hc_nr >= sizeof(kvm->arch.hypercall_exit_enabled) * 8)) How about: if (!(BIT(hc_nr) & KVM_EXIT_HYPERCALL_VALID_MASK)) KVM_EXIT_HYPERCALL_VALID_MASK is used to guard kvm->arch.hypercall_exit_enabled on KVM_CAP_EXIT_HYPERCALL, "hc_nr > maximum supported hc" AND "hc_nr <= bit_count(kvm->arch.hypercall_exit_enabled)" should be treated as invalid yet to me. > + return false; > + > + return kvm->arch.hypercall_exit_enabled & (1 << hc_nr); BIT(xx) instead of "1 << hc_nr" for better readability. > +} > #endif > -- > 2.43.2 > >