> > > struct tdx_sysinfo { > > > - struct tdx_sysinfo_tdmr_info tdmr_info; > > > + struct tdx_sysinfo_module_info module_info; > > > + struct tdx_sysinfo_module_version module_version; > > > + struct tdx_sysinfo_tdmr_info tdmr_info; > > > > Compare that to: > > > > struct tdx_sys_info { > > struct tdx_sys_info_features features; > > struct tdx_sys_info_version version; > > struct tdx_sys_info_tdmr tdmr; > > }; > > > > ...and tell me which oine is easier to read. > > I agree this is easier to read if we don't look at the JSON file. On the > other hand, following JSON file's "Class" names IMHO we can more easily > find which class to look at for a given member. > > So I think they both have pros/cons, and I have no hard opinion on this. > Hi Dan, Btw, if we aim (either now or eventually) to auto generate all metadata fields based on JSON file, I think it would be easier to name the structures based on the "Class" names. Otherwise we will need to do some class-specific tweaks.