On Wed, May 22, 2024, Binbin Wu wrote: > On 5/18/2024 1:38 AM, Sean Christopherson wrote: > > Rename kvm_cpu_cap_mask() to kvm_cpu_cap_init() in anticipation of merging > > it with kvm_cpu_cap_init_kvm_defined(), and in anticipation of _setting_ > > bits in the helper (a future commit will play macro games to set emulated > > feature flags via kvm_cpu_cap_init()). > > > > No functional change intended. > > > > Signed-off-by: Sean Christopherson <seanjc@xxxxxxxxxx> > > --- > > arch/x86/kvm/cpuid.c | 36 ++++++++++++++++++------------------ > > 1 file changed, 18 insertions(+), 18 deletions(-) > > > > diff --git a/arch/x86/kvm/cpuid.c b/arch/x86/kvm/cpuid.c > > index a802c09b50ab..5a4d6138c4f1 100644 > > --- a/arch/x86/kvm/cpuid.c > > +++ b/arch/x86/kvm/cpuid.c > > @@ -74,7 +74,7 @@ u32 xstate_required_size(u64 xstate_bv, bool compacted) > > * Raw Feature - For features that KVM supports based purely on raw host CPUID, > > * i.e. that KVM virtualizes even if the host kernel doesn't use the feature. > > * Simply force set the feature in KVM's capabilities, raw CPUID support will > > - * be factored in by kvm_cpu_cap_mask(). > > + * be factored in by __kvm_cpu_cap_mask(). > > kvm_cpu_cap_init()? Drat, yes. IIRC, I tried to get clever to avoid having to update this comment a second time, but then I ended up removing __kvm_cpu_cap_mask() entirely.