On 15/05/2024 12:01, Catalin Marinas wrote: > On Fri, Apr 12, 2024 at 09:42:11AM +0100, Steven Price wrote: >> @@ -198,6 +201,33 @@ static DEFINE_IDA(its_vpeid_ida); >> #define gic_data_rdist_rd_base() (gic_data_rdist()->rd_base) >> #define gic_data_rdist_vlpi_base() (gic_data_rdist_rd_base() + SZ_128K) >> >> +static struct page *its_alloc_shared_pages_node(int node, gfp_t gfp, >> + unsigned int order) >> +{ >> + struct page *page; >> + >> + if (node == NUMA_NO_NODE) >> + page = alloc_pages(gfp, order); >> + else >> + page = alloc_pages_node(node, gfp, order); > > I think you can just call alloc_pages_node() in both cases. This > function takes care of the NUMA_NO_NODE case itself. > >> + >> + if (page) >> + set_memory_decrypted((unsigned long)page_address(page), >> + 1 << order); >> + return page; >> +} >> + >> +static struct page *its_alloc_shared_pages(gfp_t gfp, unsigned int order) >> +{ >> + return its_alloc_shared_pages_node(NUMA_NO_NODE, gfp, order); >> +} >> + >> +static void its_free_shared_pages(void *addr, unsigned int order) >> +{ >> + set_memory_encrypted((unsigned long)addr, 1 << order); >> + free_pages((unsigned long)addr, order); >> +} > > More of a nitpick on the naming: Are these functions used by the host as > well? The 'shared' part of the name does not make much sense, so maybe > just call them its_alloc_page() etc. Yes, the host is emulating this so the pages need to be in the shared region. However this is only for realms, for a normal guest this functions obviously aren't "sharing" with anything - so perhaps dropping the 'shared' part makes sense. >> @@ -3432,7 +3468,16 @@ static struct its_device *its_create_device(struct its_node *its, u32 dev_id, >> nr_ites = max(2, nvecs); >> sz = nr_ites * (FIELD_GET(GITS_TYPER_ITT_ENTRY_SIZE, its->typer) + 1); >> sz = max(sz, ITS_ITT_ALIGN) + ITS_ITT_ALIGN - 1; >> - itt = kzalloc_node(sz, GFP_KERNEL, its->numa_node); >> + itt_order = get_order(sz); >> + page = its_alloc_shared_pages_node(its->numa_node, >> + GFP_KERNEL | __GFP_ZERO, >> + itt_order); > > How much do we waste by going for a full page always if this is going to > be used on the host? sz is a minimum of ITS_ITT_ALIGN*2-1 - which is 511 bytes. So potentially PAGE_SIZE-512 bytes could be wasted here (minus kmalloc overhead). >> + if (!page) >> + return NULL; >> + itt = (void *)page_address(page); > > page_address() has the void * type already. > Indeed, the cast is pointless. I'll remove. Thanks, Steve