This small patchset refines the ambiguous naming in kvm_pmu structure and use macros instead of magic numbers to manipulate FIXED_CTR_CTRL MSR to increase readability. No logic change is introduced in this patchset. Dapeng Mi (2): KVM: x86/pmu: Change ambiguous _mask suffix to _rsvd in kvm_pmu KVM: x86/pmu: Manipulate FIXED_CTR_CTRL MSR with macros arch/x86/include/asm/kvm_host.h | 10 ++++----- arch/x86/kvm/pmu.c | 26 ++++++++++++------------ arch/x86/kvm/pmu.h | 8 +++++--- arch/x86/kvm/svm/pmu.c | 4 ++-- arch/x86/kvm/vmx/pmu_intel.c | 36 +++++++++++++++++++-------------- 5 files changed, 46 insertions(+), 38 deletions(-) base-commit: 7b076c6a308ec5bce9fc96e2935443ed228b9148 -- 2.40.1