On Thu, Apr 25, 2024, Wei W Wang wrote: > On Thursday, April 25, 2024 10:10 PM, Sean Christopherson wrote: > > We should shorten the name to arch_caps, but I don't think that's a net > > positive, e.g. unless we do a bulk rename, it'd diverge from several other > > functions/variables, and IMO it would be less obvious that the field holds > > MSR_IA32_ARCH_CAPABILITIES. > > Yeah, the above isn't nice and no need to do bulk rename. > We could just shorten it here, e.g.: Works for me. > > > > @@ -325,11 +332,8 @@ int x86_emulate_instruction(struct kvm_vcpu > > > > *vcpu, gpa_t cr2_or_gpa, > > > > int emulation_type, void *insn, int insn_len); > > fastpath_t > > > > handle_fastpath_set_msr_irqoff(struct kvm_vcpu *vcpu); > > > > > > > > -extern u64 host_xcr0; > > > > -extern u64 host_xss; > > > > -extern u64 host_arch_capabilities; > > > > - > > > > extern struct kvm_caps kvm_caps; > > > > +extern struct kvm_host_values kvm_host; > > > > > > Have you considered merging the kvm_host_values and kvm_caps into one > > > unified structure? > > > > No really. I don't see any benefit, only the downside of having to come up > > with a name that is intuitive when reading code related to both. > > I thought the two structures perform quite similar jobs and most of the fields in > kvm_cap, e.g. has_tsc_control, supported_perf_cap, could also be interpreted > as host values? No, kvm_caps is filtered and/or generated information, e.g. supported_perf_cap and supported_xss incorporate host/hardware support, but they also incorporate KVM's own capabilities. kvm_host holds pure, unadultered host values. XSS is a perfect example. If we shoved the host value in kvm_caps, then we'd have kvm_caps.supported_xss and kvm_caps.xss, which would be incredibly confusing. So then we'd need to rename it to kvm_caps.host_xss, which is also confusing, just less so, and also results in a longer name with no added value.