PASID (Process Address Space ID) is a PCIe extension to tag the DMA transactions out of a physical device, and most modern IOMMU hardwares have supported PASID granular address translation. So a PASID-capable device can be attached to multiple hwpts (a.k.a. domains), each attachment is tagged with a pasid. This series first fixes the gap of existing set_dev_pasid() callback for supporting domain replacement, then a missing iommu API to replace domain for a pasid. Based on the iommu pasid attach/replace/detach APIs, this series adds iommufd APIs for device drivers to attach/replace/detach pasid to/from hwpt per userspace's request, and adds selftest to validate the iommufd APIs. pasid attach/replace is mandatory on Intel VT-d given the PASID table locates in the physical address space hence must be managed by the kernel, both for supporting vSVA and coming SIOV. But it's optional on ARM/AMD which allow configuring the PASID/CD table either in host physical address space or nested on top of an GPA address space. This series only add VT-d support as the minimal requirement. The completed code can be found in below link [1]. Heads up! The existing iommufd selftest was broken, there was a fix [2] to it, but not upstreamed yet. If wants to run iommufd selftest, please apply that fix. Sorry for the inconvenience. [1] https://github.com/yiliu1765/iommufd/tree/iommufd_pasid [2] https://lore.kernel.org/linux-iommu/20240111073213.180020-1-baolu.lu@xxxxxxxxxxxxxxx/ Change log: v2: - Domain replace for pasid should be handled in set_dev_pasid() callbacks instead of remove_dev_pasid and call set_dev_pasid afteward in iommu layer (Jason) - Make xarray operations more self-contained in iommufd pasid attach/replace/detach (Jason) - Tweak the dev_iommu_get_max_pasids() to allow iommu driver to populate the max_pasids. This makes the iommufd selftest simpler to meet the max_pasids check in iommu_attach_device_pasid() (Jason) v1: https://lore.kernel.org/kvm/20231127063428.127436-1-yi.l.liu@xxxxxxxxx/#r - Implemnet iommu_replace_device_pasid() to fall back to the original domain if this replacement failed (Kevin) - Add check in do_attach() to check corressponding attach_fn per the pasid value. rfc: https://lore.kernel.org/linux-iommu/20230926092651.17041-1-yi.l.liu@xxxxxxxxx/ Regards, Yi Liu Lu Baolu (1): iommu/vt-d: Add set_dev_pasid callback for nested domain Yi Liu (11): iommu: Pass old domain to set_dev_pasid op iommu: Introduce a replace API for device pasid iommufd: replace attach_fn with a structure iommufd: Support attach/replace hwpt per pasid iommu: Allow iommu driver to populate the max_pasids iommufd/selftest: Add set_dev_pasid and remove_dev_pasid in mock iommu iommufd/selftest: Add a helper to get test device iommufd/selftest: Add test ops to test pasid attach/detach iommufd/selftest: Add coverage for iommufd pasid attach/detach iommu/vt-d: Return if no dev_pasid is found in domain iommu/vt-d: Make intel_iommu_set_dev_pasid() to handle domain replacement drivers/iommu/intel/iommu.c | 29 ++- drivers/iommu/intel/iommu.h | 3 + drivers/iommu/intel/nested.c | 15 ++ drivers/iommu/intel/svm.c | 3 +- drivers/iommu/iommu-priv.h | 3 + drivers/iommu/iommu.c | 102 ++++++++- drivers/iommu/iommufd/Makefile | 1 + drivers/iommu/iommufd/device.c | 43 ++-- drivers/iommu/iommufd/iommufd_private.h | 23 ++ drivers/iommu/iommufd/iommufd_test.h | 30 +++ drivers/iommu/iommufd/pasid.c | 161 ++++++++++++++ drivers/iommu/iommufd/selftest.c | 198 ++++++++++++++++- include/linux/iommu.h | 2 +- include/linux/iommufd.h | 6 + tools/testing/selftests/iommu/iommufd.c | 207 ++++++++++++++++++ .../selftests/iommu/iommufd_fail_nth.c | 28 ++- tools/testing/selftests/iommu/iommufd_utils.h | 78 +++++++ 17 files changed, 888 insertions(+), 44 deletions(-) create mode 100644 drivers/iommu/iommufd/pasid.c -- 2.34.1