On Mon, 2024-03-18 at 19:50 -0700, Rick Edgecombe wrote: > On Wed, 2024-03-13 at 10:14 -0700, Isaku Yamahata wrote: > > > IMO, an enum will be clearer than the two flags. > > > > > > enum { > > > PROCESS_PRIVATE_AND_SHARED, > > > PROCESS_ONLY_PRIVATE, > > > PROCESS_ONLY_SHARED, > > > }; > > > > The code will be ugly like > > "if (== PRIVATE || == PRIVATE_AND_SHARED)" or > > "if (== SHARED || == PRIVATE_AND_SHARED)" > > > > two boolean (or two flags) is less error-prone. > > Yes the enum would be awkward to handle. But I also thought the way > this is specified in struct kvm_gfn_range is a little strange. > > It is ambiguous what it should mean if you set: > .only_private=true; > .only_shared=true; > ...as happens later in the series (although it may be a mistake). > > Reading the original conversation, it seems Sean suggested this > specifically. But it wasn't clear to me from the discussion what the > intention of the "only" semantics was. Like why not? > bool private; > bool shared; I see Binbin brought up this point on v18 as well: https://lore.kernel.org/kvm/6220164a-aa1d-43d2-b918-6a6eaad769fb@xxxxxxxxxxxxxxx/#t and helpfully dug up some other discussion with Sean where he agreed the "_only" is confusing and proposed the the enum: https://lore.kernel.org/kvm/ZUO1Giju0GkUdF0o@xxxxxxxxxx/ He wanted the default value (in the case the caller forgets to set them), to be to include both private and shared. I think the enum has the issues that Isaku mentioned. What about? bool exclude_private; bool exclude_shared; It will become onerous if more types of aliases grow, but it clearer semantically and has the safe default behavior.