On Fri, Mar 08, 2024 at 05:27:20PM -0800, Sean Christopherson wrote: > Date: Fri, 8 Mar 2024 17:27:20 -0800 > From: Sean Christopherson <seanjc@xxxxxxxxxx> > Subject: [PATCH v6 4/9] KVM: VMX: Move MSR_IA32_VMX_BASIC bit defines to > asm/vmx.h > X-Mailer: git-send-email 2.44.0.278.ge034bb2e1d-goog > > From: Xin Li <xin3.li@xxxxxxxxx> > > Move the bit defines for MSR_IA32_VMX_BASIC from msr-index.h to vmx.h so > that they are colocated with other VMX MSR bit defines, and with the > helpers that extract specific information from an MSR_IA32_VMX_BASIC value. > > Opportunistically use BIT_ULL() instead of open coding hex values. > > Opportunistically rename VMX_BASIC_64 to VMX_BASIC_32BIT_PHYS_ADDR_ONLY, > as "VMX_BASIC_64" is widly misleading. The flag enumerates that addresses > are limited to 32 bits, not that 64-bit addresses are allowed. > > Cc: Shan Kang <shan.kang@xxxxxxxxx> > Cc: Kai Huang <kai.huang@xxxxxxxxx> > Signed-off-by: Xin Li <xin3.li@xxxxxxxxx> > [sean: split to separate patch, write changelog] > Signed-off-by: Sean Christopherson <seanjc@xxxxxxxxxx> > --- > arch/x86/include/asm/msr-index.h | 8 -------- > arch/x86/include/asm/vmx.h | 7 +++++++ > 2 files changed, 7 insertions(+), 8 deletions(-) Reviewed-by: Zhao Liu <zhao1.liu@xxxxxxxxx>