patch kvm-remove-unused-load_segment_descriptor_to_kvm_desct.patch added to 2.6.32-stable tree

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



This is a note to let you know that we have just queued up the patch titled

    Subject: KVM: remove unused load_segment_descriptor_to_kvm_desct

to the 2.6.32-stable tree.  Its filename is

    kvm-remove-unused-load_segment_descriptor_to_kvm_desct.patch

A git repo of this tree can be found at 
    http://www.kernel.org/git/?p=linux/kernel/git/stable/stable-queue.git;a=summary


>From mtosatti@xxxxxxxxxx  Fri May  7 15:13:09 2010
From: Marcelo Tosatti <mtosatti@xxxxxxxxxx>
Date: Tue, 27 Apr 2010 13:35:26 -0300
Subject: KVM: remove unused load_segment_descriptor_to_kvm_desct
To: Greg KH <gregkh@xxxxxxx>
Cc: kvm <kvm@xxxxxxxxxxxxxxx>, Jan Kiszka <jan.kiszka@xxxxxx>, stable@xxxxxxxxxx, Gleb Natapov <gleb@xxxxxxxxxx>, Avi Kivity <avi@xxxxxxxxxx>
Message-ID: <20100427163526.GA25766@xxxxxxxx>
Content-Disposition: inline

From: Marcelo Tosatti <mtosatti@xxxxxxxxxx>

Commit 78ce64a384 in v2.6.32.12 introduced a warning due to unused
load_segment_descriptor_to_kvm_desct helper, which has been opencoded by
this commit.

On upstream, the helper was removed as part of a different commit.

Remove the now unused function.

Signed-off-by: Marcelo Tosatti <mtosatti@xxxxxxxxxx>
Signed-off-by: Greg Kroah-Hartman <gregkh@xxxxxxx>

---
 arch/x86/kvm/x86.c |   12 ------------
 1 file changed, 12 deletions(-)

--- a/arch/x86/kvm/x86.c
+++ b/arch/x86/kvm/x86.c
@@ -4155,18 +4155,6 @@ static u16 get_segment_selector(struct k
 	return kvm_seg.selector;
 }
 
-static int load_segment_descriptor_to_kvm_desct(struct kvm_vcpu *vcpu,
-						u16 selector,
-						struct kvm_segment *kvm_seg)
-{
-	struct desc_struct seg_desc;
-
-	if (load_guest_segment_descriptor(vcpu, selector, &seg_desc))
-		return 1;
-	seg_desct_to_kvm_desct(&seg_desc, selector, kvm_seg);
-	return 0;
-}
-
 static int kvm_load_realmode_segment(struct kvm_vcpu *vcpu, u16 selector, int seg)
 {
 	struct kvm_segment segvar = {


Patches currently in stable-queue which might be from mtosatti@xxxxxxxxxx are

queue-2.6.32/kvm-remove-unused-load_segment_descriptor_to_kvm_desct.patch
--
To unsubscribe from this list: send the line "unsubscribe kvm" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]
  Powered by Linux