[PATCH for-6.8 v4 0/3] KVM: LoongArch: Fix wrong CPUCFG ID handling

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


From: WANG Xuerui <git@xxxxxxxxxx>


While trying to add loongarch to the Rust kvm-bindings crate, I
accidentally discovered faulty logic in the handling of CPUCFG IDs
("leaves" for those more familiar with x86), that could result in
incorrectly accepting every possible int for the ID; fortunately it is
6.8 material that hasn't seen a release yet, so a fix is possible.

The first patch contains the fix, while the rest are general
drive-by refactoring and comment cleanups.

Although it is currently the Chinese holiday season, Huacai told me
over IM that he's able to test the series and handle the upstreaming, so
going through the loongarch tree seems to be the way forward for the

v4 changes:

- Restored the range check with `if` to simplify future additions to the
  switch cases according to Bibo's suggestion
- Require upper 32 bits of new CPUCFG values to be unset, according to
  off-list suggestion by Huacai

v3 changes:

- Fixed the validation by accepting every CPUCFG IDs from 0 to 20
  inclusive, instead of only 2; this was a misunderstanding of mine
  regarding the userland. (currently the only known user, the QEMU
  target/loongarch KVM code, expects to be able to set all these 21
  CPUCFG leaves, even though 7~15 are undefined according to the
  LoongArch reference manual.) This also had the effect of squashing the
  first 2 patches.
- Made the _kvm_get_cpucfg_mask return a mask in all valid cases,
  allowing the mask check to be lifted out of the CPUCFG2 case.
- Swapped the "LoongArch:" and "KVM:" tags because right now the patches
  are likely to reach mainline through the loongarch tree, and having
  the "LoongArch:" prefix first is the convention here.

v2 changes:

- Squashed the v1 patches 4 and 5 according to Huacai's review
- Reworded comments according to Huacai's suggestion
- Use WARN_ON_ONCE (instead of BUG) to replace unreachable() for not
  crashing the kernel (per checkpatch.pl suggestion)

WANG Xuerui (3):
  LoongArch: KVM: Fix input validation of _kvm_get_cpucfg and
  LoongArch: KVM: Rename _kvm_get_cpucfg to _kvm_get_cpucfg_mask
  LoongArch: KVM: Streamline kvm_check_cpucfg and improve comments

 arch/loongarch/kvm/vcpu.c | 81 +++++++++++++++++++--------------------
 1 file changed, 40 insertions(+), 41 deletions(-)


[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux