On Mon, Nov 13, 2023, Robert Hoo wrote: > On 11/11/2023 7:55 AM, Sean Christopherson wrote: > > When updating guest CPUID entries to emulate runtime behavior, e.g. when > > the guest enables a CR4-based feature that is tied to a CPUID flag, also > > update the vCPU's cpu_caps accordingly. This will allow replacing all > > usage of guest_cpuid_has() with guest_cpu_cap_has(). > > > > Take care not to update guest capabilities when KVM is updating CPUID > > entries that *may* become the vCPU's CPUID, e.g. if userspace tries to set > > bogus CPUID information. No extra call to update cpu_caps is needed as > > the cpu_caps are initialized from the incoming guest CPUID, i.e. will > > automatically get the updated values. > > > > Note, none of the features in question use guest_cpu_cap_has() at this > > time, i.e. aside from settings bits in cpu_caps, this is a glorified nop. > > > > Signed-off-by: Sean Christopherson <seanjc@xxxxxxxxxx> > > --- > > arch/x86/kvm/cpuid.c | 48 +++++++++++++++++++++++++++++++------------- > > 1 file changed, 34 insertions(+), 14 deletions(-) > > > > diff --git a/arch/x86/kvm/cpuid.c b/arch/x86/kvm/cpuid.c > > index 36bd04030989..37a991439fe6 100644 > > --- a/arch/x86/kvm/cpuid.c > > +++ b/arch/x86/kvm/cpuid.c > > @@ -262,31 +262,48 @@ static u64 cpuid_get_supported_xcr0(struct kvm_cpuid_entry2 *entries, int nent) > > return (best->eax | ((u64)best->edx << 32)) & kvm_caps.supported_xcr0; > > } > > +static __always_inline void kvm_update_feature_runtime(struct kvm_vcpu *vcpu, > > + struct kvm_cpuid_entry2 *entry, > > + unsigned int x86_feature, > > + bool has_feature) > > +{ > > + if (entry) > > + cpuid_entry_change(entry, x86_feature, has_feature); > > + > > + if (vcpu) > > + guest_cpu_cap_change(vcpu, x86_feature, has_feature); > > +} > > + > > static void __kvm_update_cpuid_runtime(struct kvm_vcpu *vcpu, struct kvm_cpuid_entry2 *entries, > > int nent) > > { > > struct kvm_cpuid_entry2 *best; > > + struct kvm_vcpu *caps = vcpu; > > u32 *caps = vcpu->arch.cpu_caps; > and update guest_cpu_cap_set(), guest_cpu_cap_clear(), > guest_cpu_cap_change() and guest_cpu_cap_restrict() to pass in > vcpu->arch.cpu_caps instead of vcpu, since all of them merely refer to vcpu > cap, rather than whole vcpu info. No, because then every caller would need extra code to pass vcpu->cpu_caps, and passing 'u32 *' provides less type safety than 'struct kvm_vcpu *'. That tradeoff isn't worth making this one path slightly easier to read. > Or, for simple change, here rename variable name "caps" --> "vcpu", to less > reading confusion. @vcpu is already defined and needs to be used in this function. See the comment below. I'm definitely open to a better name, though I would like to keep the name relative short so that the line lengths of the callers is reasonable, e.g. would prefer not to do vcpu_caps. > > + /* > > + * Don't update vCPU capabilities if KVM is updating CPUID entries that > > + * are coming in from userspace! > > + */ > > + if (entries != vcpu->arch.cpuid_entries) > > + caps = NULL; > > best = cpuid_entry2_find(entries, nent, 1, KVM_CPUID_INDEX_NOT_SIGNIFICANT); > > - if (best) { > > - /* Update OSXSAVE bit */ > > - if (boot_cpu_has(X86_FEATURE_XSAVE)) > > - cpuid_entry_change(best, X86_FEATURE_OSXSAVE, > > + > > + if (boot_cpu_has(X86_FEATURE_XSAVE)) > > + kvm_update_feature_runtime(caps, best, X86_FEATURE_OSXSAVE, > > kvm_is_cr4_bit_set(vcpu, X86_CR4_OSXSAVE)); > > - cpuid_entry_change(best, X86_FEATURE_APIC, > > - vcpu->arch.apic_base & MSR_IA32_APICBASE_ENABLE); > > + kvm_update_feature_runtime(caps, best, X86_FEATURE_APIC, > > + vcpu->arch.apic_base & MSR_IA32_APICBASE_ENABLE);