On Tue, Oct 10, 2023 at 10:30:31PM +0000, Oliver Upton wrote: > On Mon, Oct 09, 2023 at 11:08:52PM +0000, Raghavendra Rao Ananta wrote: > > Add a helper, kvm_arm_get_num_counters(), to read the number > > of counters from the arm_pmu associated to the VM. Make the > > function global as upcoming patches will be interested to > > know the value while setting the PMCR.N of the guest from > > userspace. > > > > Signed-off-by: Raghavendra Rao Ananta <rananta@xxxxxxxxxx> > > --- > > arch/arm64/kvm/pmu-emul.c | 17 +++++++++++++++++ > > include/kvm/arm_pmu.h | 6 ++++++ > > 2 files changed, 23 insertions(+) > > > > diff --git a/arch/arm64/kvm/pmu-emul.c b/arch/arm64/kvm/pmu-emul.c > > index a161d6266a5c..84aa8efd9163 100644 > > --- a/arch/arm64/kvm/pmu-emul.c > > +++ b/arch/arm64/kvm/pmu-emul.c > > @@ -873,6 +873,23 @@ static bool pmu_irq_is_valid(struct kvm *kvm, int irq) > > return true; > > } > > > > +/** > > + * kvm_arm_get_num_counters - Get the number of general-purpose PMU counters. > > + * @kvm: The kvm pointer > > + */ > > +int kvm_arm_get_num_counters(struct kvm *kvm) > > nit: the naming suggests this returns the configured number of PMCs, not > the limit. > > Maybe kvm_arm_pmu_get_max_counters()? Following up on the matter -- please try to avoid sending patches that add helpers without any users. Lifting *existing* logic into a helper and updating the callsites is itself worthy of a separate patch. But adding a new function called by nobody doesn't do much, and can easily be squashed into the patch that consumes the new logic. -- Thanks, Oliver