On Thu, 21 Sep 2023 13:33:17 -0700, Sean Christopherson wrote: > Fix a variety of bugs in the guest_memfd series, almost all of which are > my fault, and add assertions and testcases to detect future regressions. > > The last patch, renaming guest_mem.c to guest_memfd.c, is obviously not a > bug fix, I included it here so that if we want to go with guest_memfd.c, > squashing everything will be straightforward. > > [...] Applied to kvm-x86 guest_memfd. I'll apply Mike's hugepage fix on top (when it arrives), will send out a patch to fix the off-by-one reported by Binbin, and will post a miniseries to clean up KVM_EXIT_MEMORY_FAULT. [01/13] KVM: Assert that mmu_invalidate_in_progress *never* goes negative https://github.com/kvm-x86/linux/commit/46c10adeda81 [02/13] KVM: Actually truncate the inode when doing PUNCH_HOLE for guest_memfd https://github.com/kvm-x86/linux/commit/936144404469 [03/13] KVM: WARN if *any* MMU invalidation sequence doesn't add a range https://github.com/kvm-x86/linux/commit/1912c5dff3ac [04/13] KVM: WARN if there are danging MMU invalidations at VM destruction https://github.com/kvm-x86/linux/commit/37bbf72db864 [05/13] KVM: Fix MMU invalidation bookkeeping in guest_memfd https://github.com/kvm-x86/linux/commit/b25ab9cae30f [06/13] KVM: Disallow hugepages for incompatible gmem bindings, but let 'em succeed https://github.com/kvm-x86/linux/commit/1c297b84f3a4 [07/13] KVM: x86/mmu: Track PRIVATE impact on hugepage mappings for all memslots https://github.com/kvm-x86/linux/commit/26cf4453d2d9 [08/13] KVM: x86/mmu: Zap shared-only memslots when private attribute changes https://github.com/kvm-x86/linux/commit/fb6f779719ca [09/13] KVM: Always add relevant ranges to invalidation set when changing attributes https://github.com/kvm-x86/linux/commit/69c7916df569 [10/13] KVM: x86/mmu: Drop repeated add() of to-be-invalidated range https://github.com/kvm-x86/linux/commit/e6b1a6922470 [11/13] KVM: selftests: Refactor private mem conversions to prep for punch_hole test https://github.com/kvm-x86/linux/commit/5782107f5d2b [12/13] KVM: selftests: Add a "pure" PUNCH_HOLE on guest_memfd testcase https://github.com/kvm-x86/linux/commit/848d5faa2099 [13/13] KVM: Rename guest_mem.c to guest_memfd.c https://github.com/kvm-x86/linux/commit/6a92dc57b0e6 -- https://github.com/kvm-x86/linux/tree/next