On Mon, 14 Aug 2023 22:03:39 +0800, Yue Haibing wrote: > Commit 07f0a7bdec5c ("kvm: destroy emulated devices on VM exit") removed the > functions but not these declarations. > Commit 7ee30bc132c6 ("KVM: x86: deliver KVM IOAPIC scan request to target vCPUs") > declared but never implemented kvm_make_cpus_request_mask() > > Applied to kvm-x86 generic, though I split it into two patches. The removal of kvm_make_cpus_request_mask() is surprisingly interesting, and likely related to the spurious declaration. The exclusive/all versions use "cpus", whereas the inclusive mask helper uses "vcpus". I'm guessing the spurious declaration came in because the original author tried to match the exclusive/all versions. IMO, "vcpus" is obviously better terminology, e.g. differentiates from kvm_kick_many_cpus(), which targets physical CPUs. I think we should rename kvm_make_all_cpus_request() and kvm_make_all_cpus_request_except() to use "vcpus", but that's a much larger patch (trivial, but large). I'll send that cleanup for the 6.7 cycle. Thanks! [1/2] KVM: Remove unused kvm_device_{get,put}() declarations https://github.com/kvm-x86/linux/commit/1f8403953f05 [2/2] KVM: Remove unused kvm_make_cpus_request_mask() declaration https://github.com/kvm-x86/linux/commit/458933d33af2 -- https://github.com/kvm-x86/linux/tree/next https://github.com/kvm-x86/linux/tree/fixes