On Mon, Jul 31, 2023 at 05:23:55PM -0400, Peter Xu wrote: > On Mon, Jul 31, 2023 at 12:21:46PM -0400, Xiaoyao Li wrote: > > +bool memory_region_can_be_private(MemoryRegion *mr) > > +{ > > + return mr->ram_block && mr->ram_block->gmem_fd >= 0; > > +} > > This is not really MAP_PRIVATE, am I right? If so, is there still chance > we rename it (it seems to be also in the kernel proposal all across..)? > > I worry it can be very confusing in the future against MAP_PRIVATE / > MAP_SHARED otherwise. > > Thanks, It is - kernel calls this "map shared" but unfortunately qemu calls this just "shared". Maybe e.g. "protect_shared" would be a better name for qemu? -- MST