On 6/1/23 09:01, Nico Boehr wrote:
When toggling DAT or switch address space modes, it is likely that
s/switch/switching/
interrupts should be handled in the same DAT or address space mode.
Add a function which toggles DAT and address space mode for all
interruptions, except restart interrupts.
Signed-off-by: Nico Boehr <nrb@xxxxxxxxxxxxx>
---
lib/s390x/asm/interrupt.h | 4 ++++
lib/s390x/interrupt.c | 35 +++++++++++++++++++++++++++++++++++
lib/s390x/mmu.c | 5 +++--
3 files changed, 42 insertions(+), 2 deletions(-)
diff --git a/lib/s390x/asm/interrupt.h b/lib/s390x/asm/interrupt.h
index 35c1145f0349..55759002dce2 100644
--- a/lib/s390x/asm/interrupt.h
+++ b/lib/s390x/asm/interrupt.h
@@ -83,6 +83,10 @@ void expect_ext_int(void);
uint16_t clear_pgm_int(void);
void check_pgm_int_code(uint16_t code);
+#define IRQ_DAT_ON true
+#define IRQ_DAT_OFF false
+void irq_set_dat_mode(bool dat, uint64_t as);
+
/* Activate low-address protection */
static inline void low_prot_enable(void)
{
diff --git a/lib/s390x/interrupt.c b/lib/s390x/interrupt.c
index 3f993a363ae2..d97b5a3a7e97 100644
--- a/lib/s390x/interrupt.c
+++ b/lib/s390x/interrupt.c
@@ -9,6 +9,7 @@
*/
#include <libcflat.h>
#include <asm/barrier.h>
+#include <asm/mem.h>
#include <asm/asm-offsets.h>
#include <sclp.h>
#include <interrupt.h>
@@ -104,6 +105,40 @@ void register_ext_cleanup_func(void (*f)(struct stack_frame_int *))
THIS_CPU->ext_cleanup_func = f;
}
+/**
+ * irq_set_dat_mode - Set the DAT mode of all interrupt handlers, except for
+ * restart.
+ * This will update the DAT mode and address space mode of all interrupt new
+ * PSWs.
+ *
+ * Since enabling DAT needs initalized CRs and the restart new PSW is often used
s/initalized/initialized/
That seems to be a problematic word.
+ * to initalize CRs, the restart new PSW is never touched to avoid the chicken
+ * and egg situation.
Same here.
+ *
+ * @dat specifies whether to use DAT or not
+ * @as specifies the address space mode to use - one of AS_PRIM, AS_ACCR,
+ * AS_SECN or AS_HOME.
+ */
+void irq_set_dat_mode(bool dat, uint64_t as)
+{
+ struct psw* irq_psws[] = {
+ OPAQUE_PTR(GEN_LC_EXT_NEW_PSW),
+ OPAQUE_PTR(GEN_LC_SVC_NEW_PSW),
+ OPAQUE_PTR(GEN_LC_PGM_NEW_PSW),
+ OPAQUE_PTR(GEN_LC_MCCK_NEW_PSW),
+ OPAQUE_PTR(GEN_LC_IO_NEW_PSW),
+ NULL /* sentinel */
+ };
+
+ assert(as == AS_PRIM || as == AS_ACCR || as == AS_SECN || as == AS_HOME);
/* There are only 4 spaces */
assert(as < 4); ?
+
+ for (struct psw *psw = irq_psws[0]; psw != NULL; psw++) {
While this is ok in gnu99/c99 I generally prefer declaring the variable
outside of the loop since it's more readable when using structs and unions.
+ psw->dat = dat;
+ if (dat)
+ psw->as = as;
Does that check even matter?
+ }
+}
+
static void fixup_pgm_int(struct stack_frame_int *stack)
{
/* If we have an error on SIE we directly move to sie_exit */
diff --git a/lib/s390x/mmu.c b/lib/s390x/mmu.c
index b474d7021d3f..199bd3fbc9c8 100644
--- a/lib/s390x/mmu.c
+++ b/lib/s390x/mmu.c
@@ -12,6 +12,7 @@
#include <asm/pgtable.h>
#include <asm/arch_def.h>
#include <asm/barrier.h>
+#include <asm/interrupt.h>
#include <vmalloc.h>
#include "mmu.h"
@@ -41,8 +42,8 @@ static void mmu_enable(pgd_t *pgtable)
/* enable dat (primary == 0 set as default) */
enable_dat();
- /* we can now also use DAT unconditionally in our PGM handler */
- lowcore.pgm_new_psw.mask |= PSW_MASK_DAT;
+ /* we can now also use DAT in all interrupt handlers */
+ irq_set_dat_mode(IRQ_DAT_ON, AS_PRIM);
}
/*