On 6/2/23 03:20, Sean Christopherson wrote: > On Tue, 07 Mar 2023 21:52:33 +0800, Wei Wang wrote: >> Current KVM_BUG and KVM_BUG_ON assume that 'cond' passed from callers is >> 32-bit as it casts 'cond' to the type of int. This will be wrong if 'cond' >> provided by a caller is 64-bit, e.g. an error code of 0xc0000d0300000000 >> will be converted to 0, which is not expected. >> >> Improves the implementation by using bool in KVM_BUG and KVM_BUG_ON. >> 'bool' is preferred to 'int' as __ret is essentially used as a boolean >> and coding-stytle.rst documents that use of bool is encouraged to improve >> readability and is often a better option than 'int' for storing boolean >> values. >> >> [...] > > Applied to kvm-x86 generic, thanks! > > [1/1] KVM: allow KVM_BUG/KVM_BUG_ON to handle 64-bit cond > https://github.com/kvm-x86/linux/commit/c9d601548603 I guess this makes the !! in kvm_vm_ioctl_create_vcpu() unnecessary: KVM_BUG_ON(!!xa_store(&kvm->vcpu_array, vcpu->vcpu_idx, vcpu, 0)... Is it worth a patch (perhaps along with chopping off !! in kvm_msr_allowed() and few other places)?