On Mon, 2023-05-22 at 19:35 -0600, Gustavo A. R. Silva wrote: > Prefer struct_size() over open-coded versions. > > Link: https://github.com/KSPP/linux/issues/160 > Signed-off-by: Gustavo A. R. Silva <gustavoars@xxxxxxxxxx> Reviewed-by: Eric Farman <farman@xxxxxxxxxxxxx> > --- > drivers/s390/cio/vfio_ccw_drv.c | 3 +-- > 1 file changed, 1 insertion(+), 2 deletions(-) > > diff --git a/drivers/s390/cio/vfio_ccw_drv.c > b/drivers/s390/cio/vfio_ccw_drv.c > index 57906a9c6324..43601816ea4e 100644 > --- a/drivers/s390/cio/vfio_ccw_drv.c > +++ b/drivers/s390/cio/vfio_ccw_drv.c > @@ -171,8 +171,7 @@ static int vfio_ccw_sch_probe(struct subchannel > *sch) > return -ENODEV; > } > > - parent = kzalloc(sizeof(*parent) + sizeof(struct mdev_type > *), > - GFP_KERNEL); > + parent = kzalloc(struct_size(parent, mdev_types, 1), > GFP_KERNEL); > if (!parent) > return -ENOMEM; >