On Thu, May 11, 2023 at 04:59:12PM -0700, Sean Christopherson wrote: > Rename MMU_WARN_ON() to make it super obvious that the assertions are > all about KVM's MMU, not the primary MMU. I think adding KVM is a step in the right direction but I have 2 remaining problems with KVM_MMU_WARN_ON(): - Reminds me of VM_WARN_ON(), which toggles between WARN_ON() and BUG_ON(), whereas KVM_MMU_WARN_ON() toggles between no-op and WARN_ON(). - It's not obvious from the name that it's a no-op most of the time. Naming is hard so I might just make things worse by trying but... How about KVM_MMU_PROVE(condition). That directly pairs it with the new CONFIG_KVM_PROVE_MMU(), makes it sufficiently different from VM_WARN_ON() and WARN_ON() that readers will not make assumptions about what's happening under the hood. Also "PROVE" sounds like a high bar which conveys this might not always be enabled. That also will allow us to convert this to a WARN_ON_ONCE() (my suggestion on the other patch) without having to make the name any longer.