Quoting Pierre Morel (2023-03-20 09:56:41) [...] > diff --git a/s390x/topology.c b/s390x/topology.c > new file mode 100644 > index 0000000..ce248f1 > --- /dev/null > +++ b/s390x/topology.c > @@ -0,0 +1,180 @@ > +/* SPDX-License-Identifier: GPL-2.0-only */ > +/* > + * CPU Topology > + * > + * Copyright IBM Corp. 2022 > + * > + * Authors: > + * Pierre Morel <pmorel@xxxxxxxxxxxxx> > + */ > + > +#include <libcflat.h> > +#include <asm/page.h> > +#include <asm/asm-offsets.h> > +#include <asm/interrupt.h> > +#include <asm/facility.h> > +#include <smp.h> > +#include <sclp.h> > +#include <s390x/hardware.h> > + > +#define PTF_REQ_HORIZONTAL 0 > +#define PTF_REQ_VERTICAL 1 > +#define PTF_REQ_CHECK 2 These are all function codes, so how about we name these defines PTF_FC_... and since PTF_REQ_CHECK doesn't request anything we should rename to PTF_FC_CHECK [...] > +static struct { > + const char *name; > + void (*func)(void); > +} tests[] = { > + { "PTF", test_ptf}, missing space ^