On Mon, Feb 27, 2023 at 03:11:34AM -0800, Yi Liu wrote: > diff --git a/include/linux/vfio.h b/include/linux/vfio.h > index ce390533cb30..d12384824656 100644 > --- a/include/linux/vfio.h > +++ b/include/linux/vfio.h > @@ -43,7 +43,9 @@ struct vfio_device { > */ > const struct vfio_migration_ops *mig_ops; > const struct vfio_log_ops *log_ops; > +#if IS_ENABLED(CONFIG_VFIO_GROUP) > struct vfio_group *group; > +#endif > struct vfio_device_set *dev_set; > struct list_head dev_set_list; > unsigned int migration_flags; > @@ -58,8 +60,10 @@ struct vfio_device { > refcount_t refcount; /* user count on registered device*/ > unsigned int open_count; > struct completion comp; > +#if IS_ENABLED(CONFIG_VFIO_GROUP) > struct list_head group_next; > struct list_head iommu_entry; > +#endif > struct iommufd_access *iommufd_access; > void (*put_kvm)(struct kvm *kvm); I'd combine these for readability Jason