On 2/13/23 13:19, Huang, Kai wrote: >> On 2/13/23 03:59, Kai Huang wrote: >>> To avoid duplicated code, add a >>> helper to call SEAMCALL on all online cpus one by one but with a skip >>> function to check whether to skip certain cpus, and use that helper to >>> do the per-cpu initialization. >> ... >>> +/* >>> + * Call @func on all online cpus one by one but skip those cpus >>> + * when @skip_func is valid and returns true for them. >>> + */ >>> +static int tdx_on_each_cpu_cond(int (*func)(void *), void *func_data, >>> + bool (*skip_func)(int cpu, void *), >>> + void *skip_data) >> I only see one caller of this. Where is the duplicated code? > The other caller is in patch 15 (x86/virt/tdx: Configure global KeyID on all packages). > > I kinda mentioned this in the changelog: > > " Similar to the per-cpu module initialization, a later step to config the key for the global KeyID..." > > If we don't have this helper, then we can end up with having below loop in two functions: > > for_each_online(cpu) { > if (should_skip(cpu)) > continue; > > // call @func on @cpu. > } I don't think saving two lines of actual code is worth the opacity that results from this abstraction.