On Tue, Feb 07, 2023, Lai Jiangshan wrote: > From: Lai Jiangshan <jiangshan.ljs@xxxxxxxxxxxx> > > Use kvm_mmu_invalidate_gva() instead open calls to mmu->invlpg(). > > No functional change intended. > > Signed-off-by: Lai Jiangshan <jiangshan.ljs@xxxxxxxxxxxx> > --- > arch/x86/kvm/mmu/mmu.c | 1 + > arch/x86/kvm/vmx/nested.c | 5 ++++- > 2 files changed, 5 insertions(+), 1 deletion(-) > > diff --git a/arch/x86/kvm/mmu/mmu.c b/arch/x86/kvm/mmu/mmu.c > index 8563b52b8bb7..e03cf5558773 100644 > --- a/arch/x86/kvm/mmu/mmu.c > +++ b/arch/x86/kvm/mmu/mmu.c > @@ -5734,6 +5734,7 @@ void kvm_mmu_invalidate_gva(struct kvm_vcpu *vcpu, struct kvm_mmu *mmu, > mmu->invlpg(vcpu, gva, mmu->prev_roots[i].hpa); > } > } > +EXPORT_SYMBOL_GPL(kvm_mmu_invalidate_gva); > > void kvm_mmu_invlpg(struct kvm_vcpu *vcpu, gva_t gva) > { > diff --git a/arch/x86/kvm/vmx/nested.c b/arch/x86/kvm/vmx/nested.c > index 557b9c468734..f552f3c454b1 100644 > --- a/arch/x86/kvm/vmx/nested.c > +++ b/arch/x86/kvm/vmx/nested.c > @@ -358,6 +358,7 @@ static bool nested_ept_root_matches(hpa_t root_hpa, u64 root_eptp, u64 eptp) > static void nested_ept_invalidate_addr(struct kvm_vcpu *vcpu, gpa_t eptp, > gpa_t addr) > { > + unsigned long roots = 0; > uint i; > struct kvm_mmu_root_info *cached_root; > > @@ -368,8 +369,10 @@ static void nested_ept_invalidate_addr(struct kvm_vcpu *vcpu, gpa_t eptp, > > if (nested_ept_root_matches(cached_root->hpa, cached_root->pgd, > eptp)) > - vcpu->arch.mmu->invlpg(vcpu, addr, cached_root->hpa); > + roots |= KVM_MMU_ROOT_PREVIOUS(i); > } > + if (roots) > + kvm_mmu_invalidate_gva(vcpu, vcpu->arch.mmu, addr, roots); This is subtly buggy. On 32-bit kernels, the upper 32 bits of the GPA will get dropped. "addr" here is a gpa_t, i.e. u64, whereas kvm_mmu_invalidate_gva() takes a gva_t, i.e. unsigned long. FNAME(gva_to_gpa) just eats the misnomer, but I think I'd rather rename this path, e.g. kvm_mmu_invalidate_addr()?