On Tue, Nov 15, 2022 at 2:36 PM Borislav Petkov <bp@xxxxxxx> wrote: > > On Mon, Nov 14, 2022 at 02:11:48PM -0700, Peter Gonda wrote: > > Thanks for detailed review. Working on cleaning up the text for a V5. > > Yeah, and I have some questions in my reply which you haven't > addressed... Ah I was just applying answers to those in the comments/commit description. I have replied back to your first post. > > > > > @@ -676,7 +712,7 @@ static int __init sev_guest_probe(struct platform_device *pdev) > > > > if (!snp_dev->response) > > > > goto e_free_request; > > > > > > > > - snp_dev->certs_data = alloc_shared_pages(dev, SEV_FW_BLOB_MAX_SIZE); > > > > + snp_dev->certs_data = alloc_shared_pages(dev, sizeof(*snp_dev->certs_data)); > > > > > > What's that change for? > > > > > > I went searching for that ->certs_data only ot realize that it is an > > > array of size of SEV_FW_BLOB_MAX_SIZE elems. > > > > Do you want this change reverted? I liked the extra readability of the > > sizeof(*snp_dev->certs_data) but its unnecessary for this change. > > Really? > > I think using a define which is a SIZE define is better. Especially if > you look at > > sizeof(*snp_dev->certs_data) > > and wonder what type ->certs_data is. > > And it's not like it'll go out of sync since it is an array of size, > well, SEV_FW_BLOB_MAX_SIZE. > OK! I'll revert this part of the change.