On Mon, Nov 7, 2022 at 5:49 PM Vipin Sharma <vipinsh@xxxxxxxxxx> wrote: > > On Mon, Nov 7, 2022 at 10:30 AM David Matlack <dmatlack@xxxxxxxxxx> wrote: > > > > On Fri, Nov 04, 2022 at 09:57:03PM -0700, Vipin Sharma wrote: > > > hypercall() can be used by other hyperv tests, move it to hyperv.h. > > > > > > Signed-off-by: Vipin Sharma <vipinsh@xxxxxxxxxx> > > > --- > > > .../selftests/kvm/include/x86_64/hyperv.h | 17 +++++++++++++++++ > > > .../selftests/kvm/x86_64/hyperv_features.c | 17 ----------------- > > > 2 files changed, 17 insertions(+), 17 deletions(-) > > > > > > diff --git a/tools/testing/selftests/kvm/include/x86_64/hyperv.h b/tools/testing/selftests/kvm/include/x86_64/hyperv.h > > > index 9d8c325af1d9..87d8d9e444f7 100644 > > > --- a/tools/testing/selftests/kvm/include/x86_64/hyperv.h > > > +++ b/tools/testing/selftests/kvm/include/x86_64/hyperv.h > > > @@ -199,4 +199,21 @@ static inline uint64_t hv_linux_guest_id(void) > > > ((uint64_t)LINUX_VERSION_CODE << 16); > > > } > > > > > > +static inline uint8_t hypercall(u64 control, vm_vaddr_t input_address, > > > + vm_vaddr_t output_address, uint64_t *hv_status) > > > +{ > > > + uint8_t vector; > > > + > > > + /* Note both the hypercall and the "asm safe" clobber r9-r11. */ > > > + asm volatile("mov %[output_address], %%r8\n\t" > > > + KVM_ASM_SAFE("vmcall") > > > + : "=a" (*hv_status), > > > + "+c" (control), "+d" (input_address), > > > + KVM_ASM_SAFE_OUTPUTS(vector) > > > + : [output_address] "r"(output_address), > > > + "a" (-EFAULT) > > > + : "cc", "memory", "r8", KVM_ASM_SAFE_CLOBBERS); > > > + return vector; > > > +} > > > > Since this function is Hyper-V specific it probably makes sense to > > rename it to hyperv_hypercall() as part of moving it to library, e.g. to > > differentiate it from kvm_hypercall(). > > > > Sounds good. Does it keeping it in header file "hyperv.h" seems fine > or should I create a new "hyperv.c" lib file and move function > definition there? I think it's fine to keep in hyperv.h. It seems like the type of function we'd want to be inlined anyway, and the implementation is short.