On Mon, Sep 19, 2022, David Matlack wrote: > @@ -42,10 +42,10 @@ static struct kvm_vcpu *vcpus[KVM_MAX_VCPUS]; > * Continuously write to the first 8 bytes of each page in the > * specified region. > */ > -void perf_test_guest_code(uint32_t vcpu_idx) > +void memstress_guest_code(uint32_t vcpu_idx) > { > - struct perf_test_args *pta = &perf_test_args; > - struct perf_test_vcpu_args *vcpu_args = &pta->vcpu_args[vcpu_idx]; > + struct memstress_args *ma = &memstress_args; As a prep patch, what about renaming pta=>args? I always struggle to remember what "pta" means, and "ma" isn't any better. And that would give some amount of alignment between "args" and "vcpu_args". At a glance, I don't think using a generic name like that will be problematic.