Re: [PATCH v8 5/8] s390x/pci: enable adapter event notification for interpreted devices

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 02/09/2022 19.27, Matthew Rosato wrote:
Use the associated kvm ioctl operation to enable adapter event notification
and forwarding for devices when requested.  This feature will be set up
with or without firmware assist based upon the 'forwarding_assist' setting.

Signed-off-by: Matthew Rosato <mjrosato@xxxxxxxxxxxxx>
---
diff --git a/hw/s390x/s390-pci-bus.c b/hw/s390x/s390-pci-bus.c
index 816d17af99..e66a0dfbef 100644
--- a/hw/s390x/s390-pci-bus.c
+++ b/hw/s390x/s390-pci-bus.c
...
@@ -1428,6 +1440,8 @@ static Property s390_pci_device_properties[] = {
      DEFINE_PROP_S390_PCI_FID("fid", S390PCIBusDevice, fid),
      DEFINE_PROP_STRING("target", S390PCIBusDevice, target),
      DEFINE_PROP_BOOL("interpret", S390PCIBusDevice, interp, true),
+    DEFINE_PROP_BOOL("forwarding_assist", S390PCIBusDevice, forwarding_assist,
+                     true),
      DEFINE_PROP_END_OF_LIST(),
  };

It seems to be more common to use "-" as separator in property names than to use "_" :

$ grep -r DEFINE_PROP_BOOL * | sed -e 's/^.*("//' -e 's/".*//' | grep _ | wc -l
39
$ grep -r DEFINE_PROP_BOOL * | sed -e 's/^.*("//' -e 's/".*//' | grep - | wc -l
169

... so maybe rename "forwarding_assist" to "forwarding-assist" ?

 Thomas




[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux