RE: [PATCH 7/8] vfio: Follow the naming pattern for vfio_group_ioctl_unset_container()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



> From: Jason Gunthorpe <jgg@xxxxxxxxxx>
> Sent: Thursday, August 18, 2022 12:07 AM
> 
> Make it clear that this is the body of the ioctl - keep the mutex outside
> the function since this function doesn't have and wouldn't benefit from
> error unwind.

but doing so make unset_container() unpair with set_container() and
be the only one doing additional things in main ioctl body.

I'd prefer to moving mutex inside unset_container() for better readability.

> 
> Signed-off-by: Jason Gunthorpe <jgg@xxxxxxxxxx>
> ---
>  drivers/vfio/vfio_main.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/vfio/vfio_main.c b/drivers/vfio/vfio_main.c
> index f7b02d3fd3108b..78957f45c37a34 100644
> --- a/drivers/vfio/vfio_main.c
> +++ b/drivers/vfio/vfio_main.c
> @@ -968,7 +968,7 @@ static void __vfio_group_unset_container(struct
> vfio_group *group)
>   * the group, we know that still exists, therefore the only valid
>   * transition here is 1->0.
>   */
> -static int vfio_group_unset_container(struct vfio_group *group)
> +static int vfio_group_ioctl_unset_container(struct vfio_group *group)
>  {
>  	lockdep_assert_held_write(&group->group_rwsem);
> 
> @@ -1271,7 +1271,7 @@ static long vfio_group_fops_unl_ioctl(struct file
> *filep,
>  		return  vfio_group_ioctl_set_container(group, uarg);
>  	case VFIO_GROUP_UNSET_CONTAINER:
>  		down_write(&group->group_rwsem);
> -		ret = vfio_group_unset_container(group);
> +		ret = vfio_group_ioctl_unset_container(group);
>  		up_write(&group->group_rwsem);
>  		break;
>  	}
> --
> 2.37.2





[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux