On Tue, Aug 16 2022, Christophe JAILLET <christophe.jaillet@xxxxxxxxxx> wrote: > L and S are swapped in the message. > s/VFIO_FLS_MC/VFIO_FSL_MC/ > > Also use WARN instead of WARN_ON+dev_warn because WARN can already print > the message. > > Signed-off-by: Christophe JAILLET <christophe.jaillet@xxxxxxxxxx> > --- > Changes in v2: > * s/comment/message/ in the subject [Cornelia Huck <cohuck@xxxxxxxxxx>] > * use WARN instead of WARN_ON+dev_warn [Jason Gunthorpe <jgg@xxxxxxxx>] > > v1: > https://lore.kernel.org/all/2b65bf8d2b4d940cafbafcede07c23c35f042f5a.1659815764.git.christophe.jaillet@xxxxxxxxxx/ > --- > drivers/vfio/fsl-mc/vfio_fsl_mc.c | 4 +--- > 1 file changed, 1 insertion(+), 3 deletions(-) > > diff --git a/drivers/vfio/fsl-mc/vfio_fsl_mc.c b/drivers/vfio/fsl-mc/vfio_fsl_mc.c > index 3feff729f3ce..57774009e0eb 100644 > --- a/drivers/vfio/fsl-mc/vfio_fsl_mc.c > +++ b/drivers/vfio/fsl-mc/vfio_fsl_mc.c > @@ -108,9 +108,7 @@ static void vfio_fsl_mc_close_device(struct vfio_device *core_vdev) > /* reset the device before cleaning up the interrupts */ > ret = vfio_fsl_mc_reset_device(vdev); > > - if (WARN_ON(ret)) > - dev_warn(&mc_cont->dev, > - "VFIO_FLS_MC: reset device has failed (%d)\n", ret); > + WARN(ret, "VFIO_FSL_MC: reset device has failed (%d)\n", ret); Hm, but this drops the device information, not such a fan... maybe the author can chime in? > > vfio_fsl_mc_irqs_cleanup(vdev); >