Clean up the rmap helpers (mostly renames) to yield a more coherent set of APIs, and to purge the irritating and inconsistent "rmapp" (p is for pointer) nomenclature. Patch 1 is a tangentially related fix for a benign bug. v2: - Split up patches into smaller, more related chunks. [Paolo] - Reorder patches to put all renames at the end. [Paolo] - Avoid quadruple underscores and use more consistent names. [Paolo] v1: https://lore.kernel.org/all/20220712015558.1247978-1-seanjc@xxxxxxxxxx Sean Christopherson (7): KVM: x86/mmu: Return a u64 (the old SPTE) from mmu_spte_clear_track_bits() KVM: x86/mmu: Directly "destroy" PTE list when recycling rmaps KVM: x86/mmu: Drop the "p is for pointer" from rmap helpers KVM: x86/mmu: Rename __kvm_zap_rmaps() to align with other nomenclature KVM: x86/mmu: Rename rmap zap helpers to eliminate "unmap" wrapper KVM: x86/mmu: Rename pte_list_{destroy,remove}() to show they zap SPTEs KVM: x86/mmu: Remove underscores from __pte_list_remove() arch/x86/kvm/mmu/mmu.c | 74 +++++++++++++++++++++--------------------- 1 file changed, 37 insertions(+), 37 deletions(-) base-commit: 8031d87aa9953ddeb047a5356ebd0b240c30f233 -- 2.37.0.170.g444d1eabd0-goog