On Sun, Jun 05, 2022, Lai Jiangshan wrote: > From: Lai Jiangshan <jiangshan.ljs@xxxxxxxxxxxx> > > Make it as the opposite function of kvm_mmu_page_clear_unsync(). > > Signed-off-by: Lai Jiangshan <jiangshan.ljs@xxxxxxxxxxxx> > --- > arch/x86/kvm/mmu/mmu.c | 6 +++++- > 1 file changed, 5 insertions(+), 1 deletion(-) > > diff --git a/arch/x86/kvm/mmu/mmu.c b/arch/x86/kvm/mmu/mmu.c > index c20981dfc4fd..cc0207e26f6e 100644 > --- a/arch/x86/kvm/mmu/mmu.c > +++ b/arch/x86/kvm/mmu/mmu.c > @@ -2529,12 +2529,16 @@ static int kvm_mmu_unprotect_page_virt(struct kvm_vcpu *vcpu, gva_t gva) > return r; > } > > -static void kvm_unsync_page(struct kvm *kvm, struct kvm_mmu_page *sp) > +static void kvm_mmu_page_mark_unsync(struct kvm *kvm, struct kvm_mmu_page *sp) The existing code is anything but consistent, but I think I prefer the pattern: kvm_mmu_<action>_<target>_<flag> I.e. kvm_mmu_mark_page_unsync() + kvm_mmu_unmark_page_unsync() to yield: kvm_mmu_mark_page_unsync(kvm, sp); kvm_mmu_mark_parents_unsync(sp); so that at least this code will be consistent with itself. > { > trace_kvm_mmu_unsync_page(sp); > ++kvm->stat.mmu_unsync; > sp->unsync = 1; > +} > > +static void kvm_unsync_page(struct kvm *kvm, struct kvm_mmu_page *sp) Rather than keep kvm_unsync_page(), what about just open coding the calls in mmu_try_to_unsync_pages()? I can't imagine we'll ever have a second caller. There won't be a direct pair to kvm_sync_page(), but that's not necessarily a bad thing since they are really direct opposites anyway. > +{ > + kvm_mmu_page_mark_unsync(kvm, sp); > kvm_mmu_mark_parents_unsync(sp); > } > > -- > 2.19.1.6.gb485710b >