On Mon, 4 Jul 2022 14:13:26 +0200 Nico Boehr <nrb@xxxxxxxxxxxxx> wrote: > Upcoming changes will make use of the CPU timer, so add a convenience > function to set the CPU timer. > > Since shifts for both CPU timer and TOD clock are the same, introduce a > new define TIMING_S390_SHIFT_US. The respective shifts for CPU timer and > TOD clock reference it, so the semantic difference between the two > defines is kept. > > Signed-off-by: Nico Boehr <nrb@xxxxxxxxxxxxx> > --- > lib/s390x/asm/time.h | 16 +++++++++++++++- > 1 file changed, 15 insertions(+), 1 deletion(-) > > diff --git a/lib/s390x/asm/time.h b/lib/s390x/asm/time.h > index 7652a151e87a..9ae364afb8a3 100644 > --- a/lib/s390x/asm/time.h > +++ b/lib/s390x/asm/time.h > @@ -11,9 +11,13 @@ > #ifndef _ASMS390X_TIME_H_ > #define _ASMS390X_TIME_H_ > > -#define STCK_SHIFT_US (63 - 51) > +#define TIMING_S390_SHIFT_US (63 - 51) I would call it S390_CLOCK_SHIFT_US > + > +#define STCK_SHIFT_US TIMING_S390_SHIFT_US > #define STCK_MAX ((1UL << 52) - 1) > > +#define CPU_TIMER_SHIFT_US TIMING_S390_SHIFT_US > + > static inline uint64_t get_clock_us(void) > { > uint64_t clk; > @@ -45,4 +49,14 @@ static inline void mdelay(unsigned long ms) > udelay(ms * 1000); > } > > +static inline void cpu_timer_set(int64_t timeout_ms) I would call the function cpu_timer_set_ms so that it's clear what unit goes in, and it makes things easier if in the future someone needs a _us version > +{ > + int64_t timer_value = (timeout_ms * 1000) << CPU_TIMER_SHIFT_US; > + asm volatile ( > + "spt %[timer_value]\n" > + : > + : [timer_value] "Q" (timer_value) > + ); > +} > + > #endif