On Fri, Jun 03, 2022 at 12:41:52AM +0000, Sean Christopherson wrote: ... > +/* > + * ____vm_create() does KVM_CREATE_VM and little else. __vm_create() also > + * loads the test binary into guest memory and creates an IRQ chip (x86 only). > + */ > +struct kvm_vm *____vm_create(enum vm_guest_mode mode, uint64_t nr_pages); > +struct kvm_vm *__vm_create(enum vm_guest_mode mode, uint64_t nr_pages); > + > static inline struct kvm_vm *vm_create_barebones(void) > { > - return __vm_create(VM_MODE_DEFAULT, 0); > + return ____vm_create(VM_MODE_DEFAULT, 0); > +} > + I don't [overly] mind the "____helperhelper" naming style, but in this case wouldn't __vm_create_barebones() also be a reasonable name? Thanks, drew