Hello Thank you for the review. On Wed, May 18, 2022 at 12:57 AM David Matlack <dmatlack@xxxxxxxxxx> wrote: > > > > -static int __kvm_mmu_create(struct kvm_vcpu *vcpu, struct kvm_mmu *mmu) > > +static void __kvm_mmu_create(struct kvm_vcpu *vcpu, struct kvm_mmu *mmu) > > vcpu is now unused. Removed in V3. > > > { > > - struct page *page; > > int i; > > > > mmu->root.hpa = INVALID_PAGE; > > mmu->root.pgd = 0; > > for (i = 0; i < KVM_MMU_NUM_PREV_ROOTS; i++) > > mmu->prev_roots[i] = KVM_MMU_ROOT_INFO_INVALID; > > optional: Consider open-coding this directly in kvm_mmu_create() and > drop __kvm_mmu_create(). __kvm_mmu_create() is kept, and I don't want to duplicate this code. > > } > > > > int kvm_mmu_create(struct kvm_vcpu *vcpu) > > kvm_mmu_create() could return void now too. Did in v3. Thanks Lai