On Fri, 1 Apr 2022 at 06:00, Sean Christopherson <seanjc@xxxxxxxxxx> wrote: > > On Wed, Mar 30, 2022, Wanpeng Li wrote: > > On Wed, 30 Mar 2022 at 08:04, Sean Christopherson <seanjc@xxxxxxxxxx> wrote: > > > > diff --git a/arch/x86/include/asm/kvm_host.h b/arch/x86/include/asm/kvm_host.h > > > > index 50f011a7445a..8e05cbfa9827 100644 > > > > --- a/arch/x86/include/asm/kvm_host.h > > > > +++ b/arch/x86/include/asm/kvm_host.h > > > > @@ -861,6 +861,7 @@ struct kvm_vcpu_arch { > > > > bool preempt_count_enabled; > > > > struct gfn_to_hva_cache preempt_count_cache; > > > > } pv_pc; > > > > + bool irq_disabled; > > > > > > This is going to at best be confusing, and at worst lead to bugs The flag is > > > valid if and only if the vCPU is not loaded. I don't have a clever answer, but > > > this needs to have some form of guard to (a) clarify when it's valid and (b) actively > > > prevent misuse. > > > > How about renaming it to last_guest_irq_disabled and comments as /* > > Guest irq disabled state, valid iff the vCPU is not loaded */ > > What about usurping vcpu->run->if_flag? Userspace could manipulate the data, but > that should be fine since the data is already guest-controlled. We should at least update vcpu->run->if_flag during vcpu scheduled for the purpose of this patch, I think it looks strange for vcpu->run->if_flag. Wanpeng