Refactor and rename vm.[ch] to hardware.[ch] * Remove some uneeded #includes for vm.h * Rename vm.[ch] to hardware.[ch] * Move host_is_zvm6 to the library (was in a testcase) * Consolidate all detection functions into detect_host, which returns what host system the test is running on * Rename vm_is_* functions to host_is_*, which are then just wrappers around detect_host * Move machine type macros from arch_def.h to hardware.h, add machine types for all known machines * Add machine_is_* functions * Refactor and rename get_machine_id to be a simple wrapper for stidp * Add back get_machine_id using the stidp wrapper Claudio Imbrenda (4): s390x: remove spurious includes lib: s390: rename and refactor vm.[ch] lib: s390x: functions for machine models lib: s390x: stidp wrapper and move get_machine_id s390x/Makefile | 2 +- lib/s390x/asm/arch_def.h | 7 +- lib/s390x/hardware.h | 134 +++++++++++++++++++++++++++++++++++++++ lib/s390x/vm.h | 15 ----- lib/s390x/hardware.c | 86 +++++++++++++++++++++++++ lib/s390x/vm.c | 92 --------------------------- s390x/cpumodel.c | 4 +- s390x/mvpg-sie.c | 1 - s390x/mvpg.c | 4 +- s390x/pv-diags.c | 1 - s390x/skey.c | 28 +------- s390x/spec_ex-sie.c | 1 - s390x/uv-host.c | 4 +- 13 files changed, 230 insertions(+), 149 deletions(-) create mode 100644 lib/s390x/hardware.h delete mode 100644 lib/s390x/vm.h create mode 100644 lib/s390x/hardware.c delete mode 100644 lib/s390x/vm.c -- 2.34.1