On 3/8/22 19:55, Sean Christopherson wrote:
static void shadow_mmu_init_context(struct kvm_vcpu *vcpu, struct kvm_mmu *context,
- const struct kvm_mmu_role_regs *regs,
- union kvm_mmu_role new_role)
+ union kvm_mmu_role cpu_mode,
Can you give all helpers this treatment (rename "role" => "cpu_mode")? I got
tripped up a few times reading patches because the ones where it wasn't necessary,
i.e. where there's only a single kvm_mmu_role paramenter, were left as-is.
I think kvm_calc_shadow_npt_root_page_role() and kvm_calc_shadow_mmu_root_page_role()
are the only offenders.
These take struct kvm_mmu_role_regs; they *return* union kvm_mmu_role
but that is changed later in the series to the base part only.
Paolo