On Mon, Feb 28, 2022 at 10:33:38AM -0700, Alex Williamson wrote: > [Cc+ Bjorn, linux-pci] > > On Mon, 28 Feb 2022 09:01:14 +0000 > Shameer Kolothum <shameerali.kolothum.thodi@xxxxxxxxxx> wrote: > > > Move the PCI Device IDs of HiSilicon ACC devices to > > a common header and use a uniform naming convention. > > --- a/include/linux/pci_ids.h > > +++ b/include/linux/pci_ids.h > > @@ -2529,6 +2529,12 @@ > > #define PCI_DEVICE_ID_KORENIX_JETCARDF3 0x17ff > > > > #define PCI_VENDOR_ID_HUAWEI 0x19e5 > > +#define PCI_DEVICE_ID_HUAWEI_ZIP_PF 0xa250 > > +#define PCI_DEVICE_ID_HUAWEI_ZIP_VF 0xa251 > > +#define PCI_DEVICE_ID_HUAWEI_SEC_PF 0xa255 > > +#define PCI_DEVICE_ID_HUAWEI_SEC_VF 0xa256 > > +#define PCI_DEVICE_ID_HUAWEI_HPRE_PF 0xa258 > > +#define PCI_DEVICE_ID_HUAWEI_HPRE_VF 0xa259 We usually don't add things to pci_ids.h unless they're used in more than one place (see the comment at the top of the file). AFAICT, these device IDs are only used in one file, so you can leave the #defines in the file that uses them or use bare hex values. These device IDs are all in https://pci-ids.ucw.cz/read/PC/19e5 already, thanks for that! > > #define PCI_VENDOR_ID_NETRONOME 0x19ee > > #define PCI_DEVICE_ID_NETRONOME_NFP4000 0x4000 >