[PATCH] KVM: x86: enhance the readability of function pic_intack()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



From: wangguangju <wangguangju@xxxxxxxxx>

In function pic_intack(), use a varibale of "mask" to
record expression of "1 << irq", so we can enhance the
readability of this function.

Signed-off-by: wangguangju <wangguangju@xxxxxxxxx>
---
 arch/x86/kvm/i8259.c | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/arch/x86/kvm/i8259.c b/arch/x86/kvm/i8259.c
index 814064d06016..ad6b64b11adc 100644
--- a/arch/x86/kvm/i8259.c
+++ b/arch/x86/kvm/i8259.c
@@ -216,12 +216,14 @@ void kvm_pic_clear_all(struct kvm_pic *s, int irq_source_id)
  */
 static inline void pic_intack(struct kvm_kpic_state *s, int irq)
 {
-	s->isr |= 1 << irq;
+	int mask;
+	mask = 1 << irq;
+	s->isr |= mask;
 	/*
 	 * We don't clear a level sensitive interrupt here
 	 */
-	if (!(s->elcr & (1 << irq)))
-		s->irr &= ~(1 << irq);
+	if (!(s->elcr & mask))
+		s->irr &= ~mask;
 
 	if (s->auto_eoi) {
 		if (s->rotate_on_auto_eoi)
-- 
2.25.1




[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux