Sean Christopherson <seanjc@xxxxxxxxxx> writes: > On Tue, Dec 14, 2021, Vitaly Kuznetsov wrote: >> vmcs_to_field_offset{,_table} may sound misleading as VMCS is an opaque >> blob which is not supposed to be accessed directly. In fact, >> vmcs_to_field_offset{,_table} are related to KVM defined VMCS12 structure. >> >> No functional change intended. >> >> Signed-off-by: Vitaly Kuznetsov <vkuznets@xxxxxxxxxx> >> --- >> diff --git a/arch/x86/kvm/vmx/vmcs12.h b/arch/x86/kvm/vmx/vmcs12.h >> index 2a45f026ee11..13e2bd017538 100644 >> --- a/arch/x86/kvm/vmx/vmcs12.h >> +++ b/arch/x86/kvm/vmx/vmcs12.h >> @@ -361,10 +361,10 @@ static inline void vmx_check_vmcs12_offsets(void) >> CHECK_OFFSET(guest_pml_index, 996); >> } >> >> -extern const unsigned short vmcs_field_to_offset_table[]; >> +extern const unsigned short vmcs12_field_offset_table[]; > > While we're tweaking names, what about dropping "table" and calling this > vmcs12_field_offsets? > Ok. >> extern const unsigned int nr_vmcs12_fields; >> >> -static inline short vmcs_field_to_offset(unsigned long field) >> +static inline short vmcs12_field_offset(unsigned long field) > > And get_vmcs12_field_offset() here to make it more obvious that it's translating > something to an offset, which is communicated by the "to" in the current name. > I think we could've even used just 'vmcs12_field_offset()' as I don't see any ambiguity in it but 4 additional letters shouldn't hurt. >> { >> unsigned short offset; >> unsigned int index; >> @@ -377,7 +377,7 @@ static inline short vmcs_field_to_offset(unsigned long field) >> return -ENOENT; >> >> index = array_index_nospec(index, nr_vmcs12_fields); >> - offset = vmcs_field_to_offset_table[index]; >> + offset = vmcs12_field_offset_table[index]; >> if (offset == 0) >> return -ENOENT; >> return offset; >> -- >> 2.33.1 >> > -- Vitaly