On 01/12/2021 17.09, Christian Borntraeger wrote:
Until now we had multiple tests running under the same prefix. This can
result in multiple identical lines like
SKIP: cpumodel: dependency: facility 5 not present
SKIP: cpumodel: dependency: facility 5 not present
Make this unique by adding a proper prefix.
Signed-off-by: Christian Borntraeger <borntraeger@xxxxxxxxxxxxx>
---
s390x/cpumodel.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/s390x/cpumodel.c b/s390x/cpumodel.c
index 67bb6543f4a8..12bc82c1d0ec 100644
--- a/s390x/cpumodel.c
+++ b/s390x/cpumodel.c
@@ -116,14 +116,15 @@ int main(void)
report_prefix_push("dependency");
for (i = 0; i < ARRAY_SIZE(dep); i++) {
+ report_prefix_pushf("%d implies %d", dep[i].facility, dep[i].implied);
if (test_facility(dep[i].facility)) {
report_xfail(dep[i].expected_tcg_fail && vm_is_tcg(),
test_facility(dep[i].implied),
- "%d implies %d",
- dep[i].facility, dep[i].implied);
+ "but not available");
<bikeshedding>
Maybe rather something like "implication not correct" or so?
</bikeshedding>
} else {
report_skip("facility %d not present", dep[i].facility);
}
+ report_prefix_pop();
}
report_prefix_pop();
Reviewed-by: Thomas Huth <thuth@xxxxxxxxxx>