From: Lai Jiangshan <laijs@xxxxxxxxxxxxxxxxx> This pacheset has misc fixes and cleanups with loose dependence to each other. It includes a prevous patch that inverts and renames gpte_is_8_bytes. Ohter patches focus on the usage of vcpu->arch.walk_mmu and vcpu->arch.mmu, root_level, lpage_level. Patch 1,4,5,6,7 fixes something, but I don't think path4,5,6,7 are worth in stable tree. Lai Jiangshan (12): KVM: X86: Fix when shadow_root_level=5 && guest root_level<4 KVM: X86: Add parameter struct kvm_mmu *mmu into mmu->gva_to_gpa() KVM: X86: Remove mmu->translate_gpa KVM: X86: Use vcpu->arch.walk_mmu for kvm_mmu_invlpg() KVM: X86: Change the type of a parameter of kvm_mmu_invalidate_gva() and mmu->invlpg() to gpa_t KVM: X86: Add huge_page_level to __reset_rsvds_bits_mask_ept() KVM: X86: Add parameter huge_page_level to kvm_init_shadow_ept_mmu() KVM: VMX: Use ept_caps_to_lpage_level() in hardware_setup() KVM: X86: Rename gpte_is_8_bytes to has_4_byte_gpte and invert the direction KVM: X86: Remove mmu parameter from load_pdptrs() KVM: X86: Check root_level only in fast_pgd_switch() KVM: X86: Walk shadow page starting with shadow_root_level Documentation/virt/kvm/mmu.rst | 8 +-- arch/x86/include/asm/kvm_host.h | 23 ++++---- arch/x86/kvm/mmu.h | 16 ++++- arch/x86/kvm/mmu/mmu.c | 100 +++++++++++++++----------------- arch/x86/kvm/mmu/mmu_audit.c | 5 +- arch/x86/kvm/mmu/mmutrace.h | 2 +- arch/x86/kvm/mmu/paging_tmpl.h | 55 ++++-------------- arch/x86/kvm/mmu/tdp_mmu.c | 2 +- arch/x86/kvm/svm/nested.c | 4 +- arch/x86/kvm/svm/svm.c | 2 +- arch/x86/kvm/vmx/capabilities.h | 9 +++ arch/x86/kvm/vmx/nested.c | 12 ++-- arch/x86/kvm/vmx/vmx.c | 12 +--- arch/x86/kvm/x86.c | 55 +++++++++++------- 14 files changed, 145 insertions(+), 160 deletions(-) -- 2.19.1.6.gb485710b