On Thu, Nov 18, 2021, Paolo Bonzini wrote: > On 11/18/21 17:37, Sean Christopherson wrote: > > > It's a bit ugly in that we'd pass both @kvm and @vcpu, so that needs some more > > > thought, but at minimum it means there's no need to recalc the reserved bits. > > > > Ok, I think my final vote is to have the reserved bits passed in, but with the > > non-nested TDP reserved bits being computed at MMU init. > > Yes, and that's also where I was getting with the idea of moving part of the > "direct" MMU (man, naming these things is so hard) to struct kvm: split the > per-vCPU state from the constant one and initialize the latter just once. > Though perhaps I was putting the cart slightly before the horse. > > On the topic of naming, we have a lot of things to name: > > - the two MMU codebases: you Googlers are trying to grandfather "legacy" and > "TDP" into upstream Heh, I think that's like 99.9% me. > but that's not a great name because the former is used also when shadowing > EPT/NPT. I'm thinking of standardizing on "shadow" and "TDP" (it's not > perfect because of the 32-bit and tdp_mmu=0 cases, but it's a start). Maybe > even split parts of mmu.c out into shadow_mmu.c. But shadow is flat out wrong until EPT and NPT support is ripped out of the "legacy" MMU. > - the two walkers (I'm quite convinced of splitting that part out of struct > kvm_mmu and getting rid of walk_mmu/nested_mmu): that's easy, it can be > walk01 and walk12 with "walk" pointing to one of them I am all in favor of walk01 and walk12, the guest_mmu vs. nested_mmu confusion is painful. > - the two MMUs: with nested_mmu gone, root_mmu and guest_mmu are much less > confusing and we can keep those names. I would prefer root_mmu and nested_tdp_mmu. guest_mmu is misleading because its not used for all cases of sp->role.guest_mode=1, i.e. when L1 is not using TDP then guest_mode=1 but KVM isn't using guest_mmu.