Hello, VMX code to handle INVPCID, INVVPID, and INVEPT read the same GPR index in VM exit info. This patch series improves that handling by adding a common wrapper function for them. This series also moves INVPCID type check from both SVM and VMX to common place in kvm_handle_invpcid(). Overall, this series is just reducing duplicate code. Changes in v2: - Keeping the register read visible in the functions. - Removed INVPCID type check hardcoding and moved error condition to common function. [v1] https://lore.kernel.org/lkml/20211011194615.2955791-1-vipinsh@xxxxxxxxxx/ Vipin Sharma (2): KVM: VMX: Add a wrapper to read index of GPR for INVPCID, INVVPID, and INVEPT KVM: Move INVPCID type check from vmx and svm to the common kvm_handle_invpcid() arch/x86/kvm/svm/svm.c | 5 ----- arch/x86/kvm/vmx/nested.c | 10 ++++++---- arch/x86/kvm/vmx/vmx.c | 9 +++------ arch/x86/kvm/vmx/vmx.h | 5 +++++ arch/x86/kvm/x86.c | 3 ++- 5 files changed, 16 insertions(+), 16 deletions(-) -- 2.33.1.1089.g2158813163f-goog