On Thu, 26 Aug 2021 13:38:59 +0300 Yishai Hadas <yishaih@xxxxxxxxxx> wrote: > > Jason Gunthorpe (2): > vfio: Use select for eventfd > vfio: Use kconfig if XX/endif blocks instead of repeating 'depends on' > > Max Gurtovoy (10): > vfio/pci: Rename vfio_pci.c to vfio_pci_core.c > vfio/pci: Rename vfio_pci_private.h to vfio_pci_core.h > vfio/pci: Rename vfio_pci_device to vfio_pci_core_device > vfio/pci: Rename ops functions to fit core namings > vfio/pci: Include vfio header in vfio_pci_core.h > vfio/pci: Split the pci_driver code out of vfio_pci_core.c > vfio/pci: Move igd initialization to vfio_pci.c > PCI: Add 'override_only' field to struct pci_device_id > PCI / VFIO: Add 'override_only' support for VFIO PCI sub system > vfio/pci: Introduce vfio_pci_core.ko > > Yishai Hadas (1): > vfio/pci: Move module parameters to vfio_pci.c > > Documentation/PCI/pci.rst | 1 + > MAINTAINERS | 1 + > drivers/pci/pci-driver.c | 28 +- > drivers/vfio/Kconfig | 29 +- > drivers/vfio/fsl-mc/Kconfig | 3 +- > drivers/vfio/mdev/Kconfig | 1 - > drivers/vfio/pci/Kconfig | 40 +- > drivers/vfio/pci/Makefile | 8 +- > drivers/vfio/pci/vfio_pci.c | 2262 +---------------- > drivers/vfio/pci/vfio_pci_config.c | 70 +- > drivers/vfio/pci/vfio_pci_core.c | 2158 ++++++++++++++++ > drivers/vfio/pci/vfio_pci_igd.c | 19 +- > drivers/vfio/pci/vfio_pci_intrs.c | 42 +- > drivers/vfio/pci/vfio_pci_rdwr.c | 18 +- > drivers/vfio/pci/vfio_pci_zdev.c | 4 +- > drivers/vfio/platform/Kconfig | 6 +- > drivers/vfio/platform/reset/Kconfig | 4 +- > include/linux/mod_devicetable.h | 6 + > include/linux/pci.h | 29 + > .../linux/vfio_pci_core.h | 89 +- > scripts/mod/devicetable-offsets.c | 1 + > scripts/mod/file2alias.c | 17 +- > 22 files changed, 2525 insertions(+), 2311 deletions(-) > create mode 100644 drivers/vfio/pci/vfio_pci_core.c > rename drivers/vfio/pci/vfio_pci_private.h => include/linux/vfio_pci_core.h (56%) Applied to vfio next branch for v5.15. Thanks, Alex