On Mon, Jul 19, 2021 at 05:03:36PM +0100, Fuad Tabba wrote: > Refactor sys_regs.h and sys_regs.c to make it easier to reuse > common code. It will be used in nVHE in a later patch. > > Note that the refactored code uses __inline_bsearch for find_reg > instead of bsearch to avoid copying the bsearch code for nVHE. > > No functional change intended. > > Signed-off-by: Fuad Tabba <tabba@xxxxxxxxxx> > --- > arch/arm64/include/asm/sysreg.h | 3 +++ > arch/arm64/kvm/sys_regs.c | 30 +----------------------------- > arch/arm64/kvm/sys_regs.h | 31 +++++++++++++++++++++++++++++++ > 3 files changed, 35 insertions(+), 29 deletions(-) With the naming change suggested by Drew: Acked-by: Will Deacon <will@xxxxxxxxxx. Will