In KVM/x86 code, there are macros with the same name that are defined and used separately in the evolving code, and if the scope of the code review is only on iterations of the patch set, it can be difficult to spot these fragmented macros being defined repeatedly. IMO, it's necessary to clean this up to improve the consistency and readability of the code, and it also helps to avoid software defects caused by inconsistencies in the scope of influence of macros. Like Xu (5): KVM: x86: Clean up redundant mod_64(x, y) macro definition KVM: x86: Clean up redundant CC macro definition KVM: x86: Clean up redundant ROL16(val, n) macro definition KVM: x86: Clean up redundant __ex(x) macro definition KVM: x86: Clean up redundant pr_fmt(fmt) macro definition for svm arch/x86/include/asm/kvm_host.h | 2 ++ arch/x86/kvm/i8254.c | 6 ------ arch/x86/kvm/lapic.c | 6 ------ arch/x86/kvm/svm/avic.c | 2 -- arch/x86/kvm/svm/nested.c | 4 ---- arch/x86/kvm/svm/sev.c | 2 -- arch/x86/kvm/svm/svm.c | 4 ---- arch/x86/kvm/svm/svm.h | 3 +++ arch/x86/kvm/vmx/evmcs.c | 1 - arch/x86/kvm/vmx/evmcs.h | 4 ---- arch/x86/kvm/vmx/nested.c | 2 -- arch/x86/kvm/vmx/vmcs.h | 2 ++ arch/x86/kvm/vmx/vmcs12.c | 1 - arch/x86/kvm/vmx/vmcs12.h | 4 ---- arch/x86/kvm/vmx/vmx_ops.h | 2 -- arch/x86/kvm/x86.h | 8 ++++++++ 16 files changed, 15 insertions(+), 38 deletions(-) -- 2.32.0