On Thu, Jul 29, 2021, Ricardo Koller wrote: > On Thu, Jul 29, 2021 at 06:15:27PM +0000, Sean Christopherson wrote: > > On Thu, Jun 10, 2021, Ricardo Koller wrote: > > > + struct ucall uc; > > > + > > > + if (get_ucall(vm, vcpuid, &uc) == UCALL_UNHANDLED) { > > > > UCALL_UNHANDLED is a bit of an odd name. Without the surrounding context, I would > > have no idea that it's referring to an unhandled event, e.g. my gut reaction would > > be that it means the ucall itself was unhandled. Maybe UCALL_UNHANDLED_EVENT? > > I see. I can send a new patch (this was commited as 75275d7fbe) with a > new name. Eh, no need to post another patch. If it can be fixed up in tree, great, if not, no big deal. > The only name I can think of that's more descriptive would be > UCALL_UNHANDLED_EXCEPTION, but that's even longer. Unfortunately, EXCEPTION is incorrect as x86 will route unexpected IRQs through this as well.